Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: ComPort installation for Delphi 10 Berlin keeps leading to an error


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 1 - Last Post: Feb 22, 2017 10:09 PM Last Post By: Douglas Rudd
Toby Dobbs

Posts: 77
Registered: 9/24/16
ComPort installation for Delphi 10 Berlin keeps leading to an error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 22, 2017 2:26 AM
Hi,

I have upgraded my Delphi version from Xe6 to 10.1 and have tried to install Comport in the new version. The design-time and run-time libraries both compile, I have added the Comport, DCU and Source folders to the library path but when I insall the design-time package I get the following error:

'Access violation at address...in module bds.exe...

Can you help me fix this?
Douglas Rudd

Posts: 314
Registered: 5/16/97
Re: ComPort installation for Delphi 10 Berlin keeps leading to an error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 22, 2017 10:09 PM   in response to: Toby Dobbs in response to: Toby Dobbs
There is more than one Delphi component named "Comport". Which one is it? It may be the same one I'm using in Berlin.

You using the same version you used in XE6? Maybe there is a newer version.

Can you create a comm port in code by using the unit?

I'm using "ComPort Library ver. 4.11 Brian Gochnauer Oct 2010".
I create the com port in code. I don't have the bpl installed. Maybe it didn't install for me either.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02