Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Indy update required for TLS 1.2 ( Apple iOS ) [Remy]



Permlink Replies: 4 - Last Post: Dec 13, 2016 9:20 AM Last Post By: Dave Nottage
Mida Converter

Posts: 77
Registered: 6/2/12
Indy update required for TLS 1.2 ( Apple iOS ) [Remy]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 12, 2016 3:16 AM
Hi

Apple will require TLS v 1.2 from 1 Jan 2017, Delphi don't support it ( DataSnap - App ), are there any workaround ?

I need that DataSnap TCP mode ( standalone .exe server ) support TLS 1.2 on Berlin Update 2

Remy thank you for Indy support, Are there any update for it ?


Any link:

https://techcrunch.com/2016/06/14/apple-will-require-https-connections-for-ios-apps-by-the-end-of-2016/
https://plus.google.com/103013776067604117964/posts/b3Si46bjnwA
https://indy.fulgan.com/indy10.changelog.txt

Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: Indy update required for TLS 1.2 ( Apple iOS ) [Remy] [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 12, 2016 10:43 AM   in response to: Mida Converter in response to: Mida Converter
Mida wrotE:

Apple will require TLS v 1.2 from 1 Jan 2017, Delphi don't support it
( DataSnap - App ), are there any workaround ?

Indy has supported TLS 1.2 for awhile now. If DataSnap does not support
TLS 1.2, that is on Embarcadero.

--
Remy Lebeau (TeamB)
Markus Humm

Posts: 5,113
Registered: 11/9/03
Re: Indy update required for TLS 1.2 ( Apple iOS ) [Remy] [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 12, 2016 12:29 PM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...
Am 12.12.2016 um 19:43 schrieb Remy Lebeau (TeamB):
Mida wrotE:

Apple will require TLS v 1.2 from 1 Jan 2017, Delphi don't support it
( DataSnap - App ), are there any workaround ?

Indy has supported TLS 1.2 for awhile now. If DataSnap does not support
TLS 1.2, that is on Embarcadero.

So if ít is on EMBT the OP Mida should promptly go to QP and file a
report about this there. Then he should jump back to here and post the
report number so we can track, vote and discuss this. ;-)

Greetings

Markus
Robert Love

Posts: 155
Registered: 5/3/07
Re: Indy update required for TLS 1.2 ( Apple iOS ) [Remy] [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 12, 2016 5:19 PM   in response to: Markus Humm in response to: Markus Humm
Markus Humm wrote:
Am 12.12.2016 um 19:43 schrieb Remy Lebeau (TeamB):
Mida wrotE:

Apple will require TLS v 1.2 from 1 Jan 2017, Delphi don't support it
( DataSnap - App ), are there any workaround ?

Indy has supported TLS 1.2 for awhile now. If DataSnap does not support
TLS 1.2, that is on Embarcadero.

So if ít is on EMBT the OP Mida should promptly go to QP and file a
report about this there. Then he should jump back to here and post the
report number so we can track, vote and discuss this. ;-)

I reported it for a prior version (before Berlin) found it when doing a demo app. I says it's resolved, but I have NOT verified it.
RSP-12760

Edited by: Robert Love on Dec 13, 2016 9:20 AM
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: Indy update required for TLS 1.2 ( Apple iOS ) [Remy] [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 12, 2016 5:32 PM   in response to: Robert Love in response to: Robert Love
I reported it for a prior version found it when doing a demo app. I says it's resolved, but I have verified it.
RSP-12760

As in: it still occurs in 10.1 Berlin?

--
Dave Nottage [TeamB]
Delphi Worlds blog: http://www.delphiworlds.com/blog
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02