Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Uninstalling V10.1 Upd.1: Unable to load plug-in library



Permlink Replies: 4 - Last Post: Nov 16, 2016 7:22 PM Last Post By: Robert Small
Achim Kalwa

Posts: 70
Registered: 10/22/99
Uninstalling V10.1 Upd.1: Unable to load plug-in library
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 15, 2016 4:18 AM
Hi *,

I've just downloaded the Delphi 10.1 Update 2 ISO file, mounted it and
ran setup. It asked me to remove the previous version (Update 1). After
clicking "next" the installed failed with message:


Embarcadero RAD Studio 10.1 Berlin - InstallAware Wizard

Unable to load plug-in library. Please rebuild your project and make
sure all required plug-ins are installed.Action skipped

OK


Is that expected behavior? Which plug-in library is missing?
Jeff Overcash (...

Posts: 1,529
Registered: 9/23/99
Re: Uninstalling V10.1 Upd.1: Unable to load plug-in library
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 15, 2016 5:24 AM   in response to: Achim Kalwa in response to: Achim Kalwa
Achim Kalwa wrote:
Hi *,

I've just downloaded the Delphi 10.1 Update 2 ISO file, mounted it and
ran setup. It asked me to remove the previous version (Update 1). After
clicking "next" the installed failed with message:

Embarcadero RAD Studio 10.1 Berlin - InstallAware Wizard

Unable to load plug-in library. Please rebuild your project and make
sure all required plug-ins are installed.Action skipped

OK


Is that expected behavior? Which plug-in library is missing?

I got that doing the uninstall through the installer, then reran it with My
virus scanner of and as administrator and had no issues.

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)
Achim Kalwa

Posts: 70
Registered: 10/22/99
Re: Uninstalling V10.1 Upd.1: Unable to load plug-in library
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 15, 2016 5:38 AM   in response to: Jeff Overcash (... in response to: Jeff Overcash (...
Jeff Overcash (TeamB) wrote:

I got that doing the uninstall through the installer, then reran it with My
virus scanner of and as administrator and had no issues.

Thanks for responding.

I "solved" it by cancelling the setup, and then uninstalled using the
"remove" entry in Control Panel. After that I reinstalled using the
Setup from the new ISO image.

Achim

Malcolm Taylor

Posts: 148
Registered: 7/16/01
Re: Uninstalling V10.1 Upd.1: Unable to load plug-in library
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 16, 2016 5:55 AM   in response to: Achim Kalwa in response to: Achim Kalwa
Having read this thread, the docwiki, and having had no problem with
update 1, I decided to use the .iso installer and rely on it triggering
the uninstall.

It seemed to run smoothly and reported success, however the start menu
failed to launch the IDE as it was unable to find bds.exe!
Sure enough it was nowhere to be found on my system.

I had noted that the docwiki said the installer "should" trigger the
uninstall. Maybe the use of "should" was an informed choice!

Anyway, an uninstall followed by use of the iso installer resulted in a
working IDE.
So my advice is to perform the uninstall separately and not rely on the
installer's trigger. <bg>

Malcolm
Robert Small

Posts: 44
Registered: 5/12/98
Re: Uninstalling V10.1 Upd.1: Unable to load plug-in library
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 16, 2016 7:22 PM   in response to: Achim Kalwa in response to: Achim Kalwa
Achim Kalwa wrote:

Unable to load plug-in library. Please rebuild your project and make
sure all required plug-ins are installed.Action skipped
---------------------------

Same for me.

I clicked thorough the error message twice and then the uninstall seemed to progress OK.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02