Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Error from FastReports after installing 10.1


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 6 - Last Post: Jun 7, 2016 11:54 AM Last Post By: Antonio Estevez
Paul McManus

Posts: 11
Registered: 3/9/07
Error from FastReports after installing 10.1  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 4, 2016 3:33 PM
Launching Delphi 10.1 after installing the update now displays the following error:

Can't load package C:\Program Files (x86)\FastReports\LibD24\dclfrxtee24.bpl.
%1 is not a valid Win32 application.
Do you want to attempt to load this package the next time a project is loaded?

[Yes] [No]

Any ideas as to what this means and how I can resolve it?

Thanks.
Antonio Estevez

Posts: 665
Registered: 4/12/00
Re: Error from FastReports after installing 10.1  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 4, 2016 11:33 PM   in response to: Paul McManus in response to: Paul McManus
El 05/05/2016 a las 0:33, Paul McManus escribió:
Launching Delphi 10.1 after installing the update now displays the following error:

Can't load package C:\Program Files (x86)\FastReports\LibD24\dclfrxtee24.bpl.
%1 is not a valid Win32 application.
Do you want to attempt to load this package the next time a project is loaded?

[Yes] [No]

Any ideas as to what this means and how I can resolve it?

Thanks.

The TeeChart component is not installed (it's an optional component in the installer)

So, remove the dclfrxtee24.bpl:
Go to Component -> Install packages..., select the package from the list and press the "Remove" button.

Or run the installer again and install the TeeChar component
Paul McManus

Posts: 11
Registered: 3/9/07
Re: Error from FastReports after installing 10.1  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 5, 2016 1:51 AM   in response to: Antonio Estevez in response to: Antonio Estevez
Antonio Estevez wrote:

The TeeChart component is not installed (it's an optional component in the installer)


Thank you so much, Antonio. That was a leap I'd never have guessed was causing the problem. Adding that component solved it.
James Cogan

Posts: 2
Registered: 8/19/01
Re: Error from FastReports after installing 10.1  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 7, 2016 11:24 AM   in response to: Antonio Estevez in response to: Antonio Estevez
Antonio Estevez wrote:
The TeeChart component is not installed (it's an optional component in the installer)

So, remove the dclfrxtee24.bpl:
Go to Component -> Install packages..., select the package from the list and press the "Remove" button.

Or run the installer again and install the TeeChar component

I've recently installed Delphi 10.1 Professional and I'm missing the TeeChart component. When you say "run the installer again" how do I do that? I don't see an installer program and if I go to Windows install/update the only option is to totally remove RAD Studio 10.1.
Borja Serrano

Posts: 53
Registered: 1/10/13
Re: Error from FastReports after installing 10.1  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 7, 2016 11:36 AM   in response to: James Cogan in response to: James Cogan
Go to Tools->Manage Platforms
James Cogan

Posts: 2
Registered: 8/19/01
Re: Error from FastReports after installing 10.1  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 7, 2016 11:44 AM   in response to: Borja Serrano in response to: Borja Serrano
Borja Serrano wrote:
Go to Tools->Manage Platforms
Thanks. I didn't think Manage Platforms pertained to installing optional components. As it turned out I went back to the Web installer and add TeeChart. Obviously, Manage Platforms is the way to go.
Antonio Estevez

Posts: 665
Registered: 4/12/00
Re: Error from FastReports after installing 10.1  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 7, 2016 11:54 AM   in response to: James Cogan in response to: James Cogan
El 07/06/2016 a las 20:24, James Cogan escribió:
Antonio Estevez wrote:
The TeeChart component is not installed (it's an optional component in the installer)

So, remove the dclfrxtee24.bpl:
Go to Component -> Install packages..., select the package from the list and press the "Remove" button.

Or run the installer again and install the TeeChar component

I've recently installed Delphi 10.1 Professional and I'm missing the TeeChart component. When you say "run the installer again" how do I do that? I don't see an installer program and if I go to Windows install/update the only option is to totally remove RAD Studio 10.1.

The program that you executed to install Delphi.

Or go to

Start Menu -> All programs -> Embarcadero -> RAD Studio 10.1 Berlin

and execute "Modify, Repair, Uninstall", then select "Modify" option
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02