Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: 10.1 Install issue??



Permlink Replies: 5 - Last Post: Apr 28, 2016 10:37 AM Last Post By: Jeff Overcash (...
Ian Branch

Posts: 442
Registered: 9/23/99
10.1 Install issue??
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 19, 2016 9:12 PM
Hi Team,
OK, I seem to have done something wrong.
Downloaded and 'installed' 10.1.
Instead of updating my 10.0 to 10.1 it installed a whole new 10.1..
I now have 10.0 AND 10.1 installed and none of my third party stuff installed.
What the???
It's not as if I went from 10 to 11.....

Regards,
Ian
Linden ROTH

Posts: 467
Registered: 11/3/11
Re: 10.1 Install issue??
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 19, 2016 10:00 PM   in response to: Ian Branch in response to: Ian Branch
Ian Branch wrote:
Hi Team,
OK, I seem to have done something wrong.
Downloaded and 'installed' 10.1.
Instead of updating my 10.0 to 10.1 it installed a whole new 10.1..
I now have 10.0 AND 10.1 installed and none of my third party stuff installed.
What the???
It's not as if I went from 10 to 11.....

Regards,
Ian

that's correct that's the new version ... 10.1 Berlin is not an update to 10.0

Just ANOTHER naming convention

--
Linden
"Mango" was Cool but "Wasabi" was Hotter but remember it's all in the "source"

Ian Branch

Posts: 442
Registered: 9/23/99
Re: 10.1 Install issue?? [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 19, 2016 11:38 PM   in response to: Linden ROTH in response to: Linden ROTH
Linden ROTH wrote:

that's correct that's the new version ... 10.1 Berlin is not an update to 10.0

Just ANOTHER naming convention
Thanks Linden.

Sigh.. Just got all my 10.0 3rd party stuff sorted.
Hopefully when I uninstall 10.0 it won't affect 10.1...

Ian
Linden ROTH

Posts: 467
Registered: 11/3/11
Re: 10.1 Install issue?? [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 20, 2016 2:20 AM   in response to: Ian Branch in response to: Ian Branch
Ian Branch wrote:
Linden ROTH wrote:

that's correct that's the new version ... 10.1 Berlin is not an update to 10.0

Just ANOTHER naming convention
Thanks Linden.

Sigh.. Just got all my 10.0 3rd party stuff sorted.
Hopefully when I uninstall 10.0 it won't affect 10.1...

Ian

Don't uninstall...

--
Linden
"Mango" was Cool but "Wasabi" was Hotter but remember it's all in the "source"
Gerhard Knapp

Posts: 5
Registered: 3/1/04
Re: 10.1 Install issue??
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 28, 2016 1:53 AM   in response to: Ian Branch in response to: Ian Branch
Hello,

it's hard to reinstall on each main Version from Delphi all 3rd pary stuff.
And after installing 10.1 my 10.0 not longer worked correct.

My solution was to delete the paths for 10.1 in the system path.
So i cannot use 10.1 now.

Is there a better way to bring all installed 3rd Party components from Delphi 10.0 to 10.1?

maybe:
1. copy the 3rdparty Folder to the new tree
2. Export and Import part of the registry from 10.0 to 10.1?
3. recompile the packages?

or exists a kind of migration tool?

It is a nightmare to change to a new Delphi Version, this alone, will hold up many
users to do so.


best regards
Gerhard

Ian Branch wrote:
Hi Team,
OK, I seem to have done something wrong.
Downloaded and 'installed' 10.1.
Instead of updating my 10.0 to 10.1 it installed a whole new 10.1..
I now have 10.0 AND 10.1 installed and none of my third party stuff installed.
What the???
It's not as if I went from 10 to 11.....

Regards,
Ian
Jeff Overcash (...

Posts: 1,529
Registered: 9/23/99
Re: 10.1 Install issue??
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 28, 2016 10:37 AM   in response to: Gerhard Knapp in response to: Gerhard Knapp
Gerhard Knapp wrote:
Hello,

it's hard to reinstall on each main Version from Delphi all 3rd pary stuff.
And after installing 10.1 my 10.0 not longer worked correct.

My solution was to delete the paths for 10.1 in the system path.
So i cannot use 10.1 now.

Is there a better way to bring all installed 3rd Party components from Delphi 10.0 to 10.1?

maybe:
1. copy the 3rdparty Folder to the new tree
2. Export and Import part of the registry from 10.0 to 10.1?
3. recompile the packages?

You must change the run time suffix to 240 (or something that won't conflict
with 10.0's name. This is what is causing you your issues.

Design time packages have their full paths known, but the run time is loaded
through the OS load dll procedures. Since 10.1 is earlier in the path if you
have two run times both with 230 as their suffix, the 10.1 is linking to rtl240,
the 10.0 is linking to rtl230. This means the 10.1 version can not be used in
10.0, and the 10.0 version can not be used in 10.1.

Runtime packages must have unique names across versions.

or exists a kind of migration tool?

It is a nightmare to change to a new Delphi Version, this alone, will hold up many
users to do so.


It is no different than it has been since D3 when packages were introduced.

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02