Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Can I disable the stupid paren auto complete?


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 5 - Last Post: Jan 6, 2016 9:54 AM Last Post By: Jessie Potts
William Egge

Posts: 98
Registered: 11/29/06
Can I disable the stupid paren auto complete?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 3, 2015 6:15 AM
If I highlight any text, even inside of a string, and press either (, [, or { then the IDE assumes I want to wrap my selection into a paren. I don't code like that, if I highlight something and press a key I expect my highlighted text to be replaced with what I type.

Is there a way to disable the paren auto complete? I am not so stupid I don't know how to put parens around things by myself.
Tom Brunberg

Posts: 329
Registered: 12/27/04
Re: Can I disable the stupid paren auto complete?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 3, 2015 7:49 AM   in response to: William Egge in response to: William Egge
William Egge wrote:

If I highlight any text, even inside of a string, and press either (, [, or { then the IDE
assumes I want to wrap my selection into a paren. I don't code like that, if I highlight
something and press a key I expect my highlighted text to be replaced with what I type.

Is there a way to disable the paren auto complete? I am not so stupid I don't know how to put
parens around things by myself.

William,
You did not say which Delphi version you have, but I assume it is one of the recent ones including
Castalia. I have XE7 and indeed the same auto-parens works here.
Now, I looked through all settings (from menu: Castalia - Castalia options) but could not find
anything specific for auto-parens. Maybe there is your version? There is also a Castalia Help that
you may want to take a look at.

--
Tom Brunberg
firstname.lastname@welho.com
William Egge

Posts: 98
Registered: 11/29/06
Re: Can I disable the stupid paren auto complete?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 3, 2015 8:34 AM   in response to: Tom Brunberg in response to: Tom Brunberg
Tom Brunberg wrote:
William,
You did not say which Delphi version you have, but I assume it is one of the recent ones including
Castalia. I have XE7 and indeed the same auto-parens works here.
Now, I looked through all settings (from menu: Castalia - Castalia options) but could not find
anything specific for auto-parens. Maybe there is your version? There is also a Castalia Help that
you may want to take a look at.

--
Tom Brunberg
firstname dot lastname at welho dot com

Seattle 10. I could not find Castalia in the settings nor any settings related to "overwrite my code as I type". I could only find Formatter settings, which are only applied when explicitly invoked and the standard Delphi auto-indent type stuff and Code Insight. Code insight has an "auto parens" setting but it appears to apply to something else.

I believe I heard Seattle 10 embedded Castalia into the IDE and not as an outside plugin. Maybe that is why there is no menu for it.
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: Can I disable the stupid paren auto complete?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 3, 2015 10:23 AM   in response to: William Egge in response to: William Egge
William wrote:

I believe I heard Seattle 10 embedded Castalia into the IDE
and not as an outside plugin.

In XE8 and RAD Studio Seattle RTM, Castalia was implemented as an IDE package
that could be disabled by either:

1. editing the Registry. Go to the "HKEY_CURRENT_USER\Software\Embarcadero\BDS\16.0\Known
IDE Packages" key and place an underscore in front of the description for
the Castalia package.

2. running the IDE with the /NOCASTALIA command-line parameter.

But, in RAD Studio Seattle Update 1, Castalia is now integrated directly
into the IDE and the above options have been removed.

--
Remy Lebeau (TeamB)
Quentin Correll


Posts: 2,412
Registered: 12/1/99
Re: Can I disable the stupid paren auto complete?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 3, 2015 5:05 PM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...
Remy,

| But, in RAD Studio Seattle Update 1, Castalia is now integrated
| directly into the IDE and the above options have been removed.

One of the several reasons why I removed RAD Studio Seattle from my
program development environment and am sticking with RAD Studio XE8 for
as long as it works for me!!!

--

Q -- XanaNews 1.19.1.372 - 2015-12-03 17:03:37
Jessie Potts

Posts: 13
Registered: 8/2/08
Re: Can I disable the stupid paren auto complete?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 6, 2016 9:54 AM   in response to: William Egge in response to: William Egge
Is there a way to disable the paren auto complete?

Yep!

In the Options dialog, go to Editor Options\Key Mappings and uncheck the "Smart Surround Keys" item in the Enhancement modules list. That should do the trick.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02