Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: How can I avoid single stepping into assembler?


This question is answered.


Permlink Replies: 6 - Last Post: Nov 9, 2015 5:03 PM Last Post By: Mark Patterson
Mark Patterson

Posts: 15
Registered: 5/28/07
How can I avoid single stepping into assembler?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 4, 2015 6:40 PM
Hi

When debugging I only want to read my own code, but I keep F7-ing into assembler and other library code. I have tried to sort this out before, but it is not obvious.

I'm using Xe5.

TIA
Mark
Nicholas Ring

Posts: 54
Registered: 8/22/97
Re: How can I avoid single stepping into assembler?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 4, 2015 10:47 PM   in response to: Mark Patterson in response to: Mark Patterson
Mark Patterson wrote:

When debugging I only want to read my own code, but I keep F7-ing
into assembler and other library code. I have tried to sort this out
before, but it is not obvious.

You could try
http://www.uweraabe.de/Blog/2015/05/08/selective-debugging/ Hopefully
it will help out.

Cheers,
Nick

--
Sent from my XanaNews v1.19.1.373
Cesar Romero


Posts: 462
Registered: 3/22/00
Re: How can I avoid single stepping into assembler?
Correct
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 5, 2015 8:17 AM   in response to: Mark Patterson in response to: Mark Patterson
Mark Patterson wrote:

When debugging I only want to read my own code, but I keep F7-ing
into assembler and other library code. I have tried to sort this out
before, but it is not obvious.

I'm using Xe5.

Do you need to debug RTL/VCL?
If not, remove Debug DCU from Build options.

[]s

Cesar Romero

Mark Patterson

Posts: 15
Registered: 5/28/07
Re: How can I avoid single stepping into assembler?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 5, 2015 5:43 PM   in response to: Cesar Romero in response to: Cesar Romero
Cesar Romero wrote:

Do you need to debug RTL/VCL?
If not, remove Debug DCU from Build options.

Thanks for replying. I looked around for what you mentioned. In Project | Options | Delphi Compiler | Compiling | Debugging I found a check-box option "Use debug .dcus". It is already false.

So either that is not the option you meant, or something else is overriding it.

Do you have any further light on this?

Regards
Mark

Edited by: Mark Patterson on Nov 6, 2015 11:43 AM

Edited by: Mark Patterson on Nov 6, 2015 11:44 AM

Mark Patterson

Posts: 15
Registered: 5/28/07
Re: How can I avoid single stepping into assembler?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 5, 2015 6:17 PM   in response to: Mark Patterson in response to: Mark Patterson
Mark Patterson wrote:
Cesar Romero wrote:

Do you need to debug RTL/VCL?
If not, remove Debug DCU from Build options.

Thanks for replying. I looked around for what you mentioned. In Project | Options | Delphi Compiler | Compiling | Debugging I found a check-box option "Use debug .dcus". It is already false.

So either that is not the option you meant, or something else is overriding it.

Do you have any further light on this?

Regards
Mark


Ah, sorry, I was confused. I was debugging the same code in 2 different projects. It seems that Use debug DCSu is on be default. I tried f7-ing with that option on then off, and does seem to determine whether the assembler comes up.

Thanks
Cesar Romero


Posts: 462
Registered: 3/22/00
Re: How can I avoid single stepping into assembler? [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 6, 2015 5:15 AM   in response to: Mark Patterson in response to: Mark Patterson
Mark Patterson wrote:

Thanks for replying. I looked around for what you mentioned. In
Project | Options | Delphi Compiler | Compiling | Debugging I found a
check-box option "Use debug .dcus". It is already false.

So either that is not the option you meant, or something else is
overriding it.

Do you have any further light on this?

Are you sure?

Did you select the Debug Target platform on the form top?

After you do that, you have to "Build" your project, not only compile.

Regards,

Cesar Romero

Mark Patterson

Posts: 15
Registered: 5/28/07
Re: How can I avoid single stepping into assembler? [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 9, 2015 5:03 PM   in response to: Cesar Romero in response to: Cesar Romero
Cesar Romero wrote:
Are you sure?

My reply correcting my error arrived before yours. Sorry, i was wrong. I was looking at two different projects, with different settings for "Use debug .dcus".

---
Mark
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02