Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Can't install Synedit on 10 Seattle, AV error in IDE.



Permlink Replies: 2 - Last Post: Sep 28, 2015 2:28 AM Last Post By: Andy Kozakewycz
Andy Kozakewycz

Posts: 46
Registered: 11/9/01
Can't install Synedit on 10 Seattle, AV error in IDE.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 17, 2015 4:06 AM
Can't install Synedit (latest unicode version) on 10 Seattle.

Works fine on all previous versions, won't install into the 10 IDE.

Compiles/builds OK, but when trying to install causes error

"Access violation at address 27158679 in module 'bds.exe'. Read of address 00000010"

Since the error is in the IDE there is no chance to debug the installation.
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: Can't install Synedit on 10 Seattle, AV error in IDE.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 17, 2015 9:05 AM   in response to: Andy Kozakewycz in response to: Andy Kozakewycz
Andy wrote:

Compiles/builds OK, but when trying to install causes error

"Access violation at address 27158679 in module 'bds.exe'. Read
of address 00000010"

A nil pointer is being accessed.

Does SynEdit use any design-time code that might be breaking in 10? Maybe
it is accessing an IDE interface that does not work anymore?

Since the error is in the IDE there is no chance to debug the
installation.

Have you tried debugging the IDE itself? You can run a second instance of
the IDE and have the other instance debug it. Good way to debug component
installation issues.

--
Remy Lebeau (TeamB)
Andy Kozakewycz

Posts: 46
Registered: 11/9/01
Re: Can't install Synedit on 10 Seattle, AV error in IDE.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 28, 2015 12:11 AM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...
Remy Lebeau (TeamB) wrote:
Andy wrote:

Compiles/builds OK, but when trying to install causes error

"Access violation at address 27158679 in module 'bds.exe'. Read
of address 00000010"

A nil pointer is being accessed.

Does SynEdit use any design-time code that might be breaking in 10? Maybe
it is accessing an IDE interface that does not work anymore?

Since the error is in the IDE there is no chance to debug the
installation.

Have you tried debugging the IDE itself? You can run a second instance of
the IDE and have the other instance debug it. Good way to debug component
installation issues.

--
Remy Lebeau (TeamB)

Hi Remy,

Been on holiday so didn't have to time to chase this up.

How do I do that?

Andy

Edit: I have a fix, someone on Stack overload pointed out that there was a DX version on Getit and that version works.

Edited by: Andy Kozakewycz on Sep 28, 2015 2:27 AM

Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02