Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Delphi 10 Seattle and OSX not working.


This question is answered.


Permlink Replies: 3 - Last Post: Sep 29, 2015 1:33 PM Last Post By: E Spelt
E Spelt

Posts: 24
Registered: 12/26/09
Delphi 10 Seattle and OSX not working.  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 27, 2015 7:39 AM
Hi

In Delphi 10 Seattle I get errors deploying/running applications to OSX. For instance if I try to run the demo BLEScanner I get from the PAServer(v17.0):

Reason: Incompatible library version: BLEScanner requires version 112.0.0 or later, but libSystem.B.dylib provides version 1.0.0

- Reinstalled Xcode to the latest
- Reinstalled the SDK's
- Resetted PAServer.

Don't get it to work at all.

Any ideas?

Thanks Edward
Eli M

Posts: 1,346
Registered: 11/9/13
Re: Delphi 10 Seattle and OSX not working.  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 27, 2015 8:53 AM   in response to: E Spelt in response to: E Spelt
https://plus.google.com/+AntonelloCarlomagno73/posts/2Hon4asq8Be

"Antonello Carlomagno

you can download the xcode 6.4 with your developer account from here:

http://adcdownload.apple.com/Developer_Tools/Xcode_6.4/Xcode_6.4.dmg

do not install the 6.4 xcode.

extract from content xcode.app (6.4) the osx sdk 10.9.5 ... and add into content xcode.app 7.0 ...

then, add the new SDK into Delphi ...

your OSX now will work "
CM&V Hackbart S...

Posts: 16
Registered: 8/3/04
Re: Delphi 10 Seattle and OSX not working.
Correct
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 29, 2015 1:58 AM   in response to: E Spelt in response to: E Spelt
E Spelt wrote:
Hi

In Delphi 10 Seattle I get errors deploying/running applications to OSX. For instance if I try to run the demo BLEScanner I get from the PAServer(v17.0):

Reason: Incompatible library version: BLEScanner requires version 112.0.0 or later, but libSystem.B.dylib provides version 1.0.0

- Reinstalled Xcode to the latest
- Reinstalled the SDK's
- Resetted PAServer.

Don't get it to work at all.

Any ideas?

Thanks Edward

I have had the same problem. The solution is quite "easy". Go to the MacOS Folder located under $(BDSPLATFORMSDKSDIR)\MacOSX10.11.sdk and under the subfolder usr\lib remove the libSystem.dylib file.
E Spelt

Posts: 24
Registered: 12/26/09
Re: Delphi 10 Seattle and OSX not working.  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 29, 2015 1:33 PM   in response to: CM&V Hackbart S... in response to: CM&V Hackbart S...
CM&V Hackbart Softwareentwickler wrote:
E Spelt wrote:
Hi

In Delphi 10 Seattle I get errors deploying/running applications to OSX. For instance if I try to run the demo BLEScanner I get from the PAServer(v17.0):

Reason: Incompatible library version: BLEScanner requires version 112.0.0 or later, but libSystem.B.dylib provides version 1.0.0

- Reinstalled Xcode to the latest
- Reinstalled the SDK's
- Resetted PAServer.

Don't get it to work at all.

Any ideas?

Thanks Edward

I have had the same problem. The solution is quite "easy". Go to the MacOS Folder located under $(BDSPLATFORMSDKSDIR)\MacOSX10.11.sdk and under the subfolder usr\lib remove the libSystem.dylib file.

Thanks, this one was the easy solution.

Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02