Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Error: Invalid pointer operation.


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 0
Nicholas Gessler

Posts: 20
Registered: 1/25/98
Error: Invalid pointer operation.  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 5, 2015 6:32 PM
I have been writing code in XE6 on Dell desktops successfully, posting the project files on my website:
https://web.duke.edu/isis/gessler/borland/
and reopening the project and migrating files from RadStudio2010 successfully.

I just had XE6 installed on my Surface Pro 2 and am running into "Invalid pointer operation" messages.

Sometimes XE6 simply freezes up and I have to close it from the task manager.
Sometimes, after I wait a while, XE6 will compile and run and show the message again.

The message details begin with:
[50065E6C]{rtl200.bpl } System.TInterfacedObject.BeforeDestruction (Line 36441, "System.pas" + 1) + $2
[50059BAE]{rtl200.bpl } System.ErrorAt (Line 5284, "System.pas" + 3) + $4
[50059BF2]{rtl200.bpl } System.Error (Line 5295, "System.pas" + 1) + $7
[50065E6C]{rtl200.bpl } System.TInterfacedObject.BeforeDestruction (Line 36441, "System.pas" + 1) + $2
(Note the two lines with the word "error")

And end with:
[501766E4]{rtl200.bpl } System.Classes.StdWndProc (Line 17064, "System.Classes.pas" + 6) + $1
[50642EDF]{vcl200.bpl } Vcl.Forms.TApplication.ProcessMessage (Line 10351, "Vcl.Forms.pas" + 23) + $1
[50642F22]{vcl200.bpl } Vcl.Forms.TApplication.HandleMessage (Line 10381, "Vcl.Forms.pas" + 1) + $4
[50643255]{vcl200.bpl } Vcl.Forms.TApplication.Run (Line 10519, "Vcl.Forms.pas" + 26) + $3

Can anyone explain to me what is going on?
I'm preparing to teach an intro to "Complex Systems" at Duke Kunshan University and need to get a handle on this soon.

Thank you, Nick

Thanks, Nick

Edited by: Nicholas Gessler on Jun 6, 2015 7:59 AM
Since the error messages reference "rtl200.bpl" I decided to set all Runtime Library (RTL) options to "false" during the migration from RadStudio2010 to XE6.
That worked on the one occasion that I tried it. I will do more trials tomorrow...
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02