Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Bug IW 14.0.36



Permlink Replies: 5 - Last Post: Jan 8, 2015 3:20 AM Last Post By: Alexandre Machado
Nelson Allein J...

Posts: 10
Registered: 10/8/05
Bug IW 14.0.36
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 17, 2014 4:29 AM
*** PORTUGUÊS ***
Gostaria de reportar um comportamento do IW que entendo como BUG.

no componente IWFILEUPLOADER surgem caracteres estranhos no evendo "IWFileUploader1AsyncUploadCompleted" na variavel "FileName" que pode ser decodificado com a função "Utf8ToAnsi()", porém somente para PUBLICAÇÃO EM SERVIDORES IIS modo ISAPI. Em modo STANDALONE não há problemas.

na criação do componente TIWIMAGEFILE em tempo de execução, houve uma mudança de comportamento, onde antes era possível atribuir valores de HEIGHT e WIDTH e a imagem se adaptava as medidas atribuidas, agora não mais, para tampar uma area específica não é mais possível, e para tampar todo o fundo do form, é necessário usar a opção de ALIGN=alClient.

Link para download do fonte Exemplo versão 14.0.36: https://drive.google.com/open?id=0B5quDjlSO9QjeHdjYnNRbW1vWnc&authuser=0

link para video youtube.com: http://youtu.be/iF3lh34rBQg

*** TRANSLATE GOOGLE.COM ***
I would like to report one IW behavior that understand how BUG.

in IWFILEUPLOADER component appear strange characters in evendo "IWFileUploader1AsyncUploadCompleted" in the variable "FileName" that can be decoded with the "Utf8ToAnsi ()" function, but only for PUBLICATION IN SERVERS IIS ISAPI mode. In STANDALONE so no problems there.

in the creation of TIWIMAGEFILE component at runtime, there was a change in behavior, where it was possible to assign values HEIGHT and WIDTH and the image was adapted the assigned measures, no longer to cover a specific area is no longer possible, and to plug any form of background, you must use the option of ALIGN = alClient.

Link to download the example source version 14.0.36: https://drive.google.com/open?id=0B5quDjlSO9QjeHdjYnNRbW1vWnc&authuser=0

link to video youtube.com: http://youtu.be/iF3lh34rBQg

Edited by: Nelson Allein Junior on Dec 17, 2014 5:13 AM

Nelson Allein J...

Posts: 10
Registered: 10/8/05
Re: Bug IW 14.0.36
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 19, 2014 5:36 AM   in response to: Nelson Allein J... in response to: Nelson Allein J...
Nelson Allein Junior wrote:
*** PORTUGUÊS ***
Gostaria de reportar um comportamento do IW que entendo como BUG.

no componente IWFILEUPLOADER surgem caracteres estranhos no evendo "IWFileUploader1AsyncUploadCompleted" na variavel "FileName" que pode ser decodificado com a função "Utf8ToAnsi()", porém somente para PUBLICAÇÃO EM SERVIDORES IIS modo ISAPI. Em modo STANDALONE não há problemas.

na criação do componente TIWIMAGEFILE em tempo de execução, houve uma mudança de comportamento, onde antes era possível atribuir valores de HEIGHT e WIDTH e a imagem se adaptava as medidas atribuidas, agora não mais, para tampar uma area específica não é mais possível, e para tampar todo o fundo do form, é necessário usar a opção de ALIGN=alClient.

Link para download do fonte Exemplo versão 14.0.36: https://drive.google.com/open?id=0B5quDjlSO9QjeHdjYnNRbW1vWnc&authuser=0

link para video youtube.com: http://youtu.be/iF3lh34rBQg

*** TRANSLATE GOOGLE.COM ***
I would like to report one IW behavior that understand how BUG.

in IWFILEUPLOADER component appear strange characters in evendo "IWFileUploader1AsyncUploadCompleted" in the variable "FileName" that can be decoded with the "Utf8ToAnsi ()" function, but only for PUBLICATION IN SERVERS IIS ISAPI mode. In STANDALONE so no problems there.

in the creation of TIWIMAGEFILE component at runtime, there was a change in behavior, where it was possible to assign values HEIGHT and WIDTH and the image was adapted the assigned measures, no longer to cover a specific area is no longer possible, and to plug any form of background, you must use the option of ALIGN = alClient.

Link to download the example source version 14.0.36: https://drive.google.com/open?id=0B5quDjlSO9QjeHdjYnNRbW1vWnc&authuser=0

link to video youtube.com: http://youtu.be/iF3lh34rBQg

Edited by: Nelson Allein Junior on Dec 17, 2014 5:13 AM


Anyone have any suggestions? Had a similar experience?

Nelson Allein J...

Posts: 10
Registered: 10/8/05
Re: Bug IW 14.0.36
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 7:33 AM   in response to: Nelson Allein J... in response to: Nelson Allein J...
RESOLVIDO TIWIMAGEFILE:

A respeito do IWIMAGEFILE a propriedade USESIZE deve estar FALSE que o objeto assume suas formas conforme o tamanho passado como parâmetro.

************************ TRANSLATE GOOGLE.COM ************************

RESOLVED TIWIMAGEFILE:

Regarding the IWIMAGEFILE USESIZE property must be false that the object takes its forms as the last size as a parameter.

Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: Bug IW 14.0.36
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 23, 2014 12:56 PM   in response to: Nelson Allein J... in response to: Nelson Allein J...
Hi,

AFAIK, this is not a IW bug, but another WebBroker-related bug present in all Delphi versions that I was able to test until now (at least from D2009 to DXE5, included).

We are still testing a new workaround for it.

We should have a definitive answer soon.
Nelson Allein J...

Posts: 10
Registered: 10/8/05
Re: Bug IW 14.0.36
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 24, 2014 2:31 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
Hi,

AFAIK, this is not a IW bug, but another WebBroker-related bug present in all Delphi versions that I was able to test until now (at least from D2009 to DXE5, included).

We are still testing a new workaround for it.

We should have a definitive answer soon.

*** TRANSLATE BY GOOGLE.COM ***

ok, thanks for the feedback.
MERRY CHRISTMAS TO ALL!
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: Bug IW 14.0.36
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 8, 2015 3:20 AM   in response to: Nelson Allein J... in response to: Nelson Allein J...
Nelson Allein Junior wrote:
Alexandre Machado wrote:
Hi,

AFAIK, this is not a IW bug, but another WebBroker-related bug present in all Delphi versions that I was able to test until now (at least from D2009 to DXE5, included).

We are still testing a new workaround for it.

We should have a definitive answer soon.

I can confirm that this is a WebBroker bug, not IW. We should have a workaround working in the next release.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02