Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: XE7 Component Toolbar duplicate controls


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 8 - Last Post: Jan 13, 2015 10:10 AM Last Post By: Stephan St-Denis
Alan Marryat

Posts: 28
Registered: 3/14/01
XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 8:39 AM
Not a big problem, but I have noticed that when the Component Toolbar is enabled, going to the Standard tab, I can see TPanel and TActionlist twice on there. Once near the left side, and again near the right end of the toolbar.
quinn wildman

Posts: 856
Registered: 12/2/99
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 12:29 PM   in response to: Alan Marryat in response to: Alan Marryat
It sounds like you are using the classic undocked layout here, which I
imagine is significant. However, I tried Classic Undocked and the
Default Layout and cannot observe this behavior either way. I recommend
you launch your IDE with the -r command line switch as shown here:
http://support.embarcadero.com/article/42597 as a starting place. I
expect your problem will not happen at this point. If you can describe
the steps you take after this point to observe your issue that might be
useful.

Alan Marryat wrote:
Not a big problem, but I have noticed that when the Component Toolbar is enabled, going to the Standard tab, I can see TPanel and TActionlist twice on there. Once near the left side, and again near the right end of the toolbar.
Alan Marryat

Posts: 28
Registered: 3/14/01
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 1:11 PM   in response to: quinn wildman in response to: quinn wildman
quinn wildman wrote:
It sounds like you are using the classic undocked layout here, which I
imagine is significant. However, I tried Classic Undocked and the
Default Layout and cannot observe this behavior either way. I recommend
you launch your IDE with the -r command line switch as shown here:
http://support.embarcadero.com/article/42597 as a starting place. I
expect your problem will not happen at this point. If you can describe
the steps you take after this point to observe your issue that might be
useful.

Alan Marryat wrote:
Not a big problem, but I have noticed that when the Component Toolbar is enabled, going to the Standard tab, I can see TPanel and TActionlist twice on there. Once near the left side, and again near the right end of the toolbar.

No I am using the default. Tried it with the -rfoo option on startup, and then there are only a handful of controls on that toolbar.

Simply run Delphi, go to the View Menu, to Toolbars, and check Component. Then notice on the "Standard" tab that there are duplicates.
quinn wildman

Posts: 856
Registered: 12/2/99
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 3:04 PM   in response to: Alan Marryat in response to: Alan Marryat
Alan Marryat wrote:
Simply run Delphi, go to the View Menu, to Toolbars, and check Component. Then notice on the "Standard" tab that there are duplicates.

I cannot reproduce the reported behavior. No matter what I do, TPanel
and TActionList only show up once in the standard group.
quinn wildman

Posts: 856
Registered: 12/2/99
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 3:10 PM   in response to: quinn wildman in response to: quinn wildman
Oh, I see it now. Some artifact of using the old component toolbar. If
you want it investigated for future versions, please submit it to
http://quality.embarcadero.com. Or, just the tool palette instead, which
is what I think most people do.

quinn wildman wrote:
Alan Marryat wrote:
Simply run Delphi, go to the View Menu, to Toolbars, and check Component. Then notice on the "Standard" tab that there are duplicates.

I cannot reproduce the reported behavior. No matter what I do, TPanel
and TActionList only show up once in the standard group.
Alan Marryat

Posts: 28
Registered: 3/14/01
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 3:16 PM   in response to: quinn wildman in response to: quinn wildman
quinn wildman wrote:
Oh, I see it now. Some artifact of using the old component toolbar. If
you want it investigated for future versions, please submit it to
http://quality.embarcadero.com. Or, just the tool palette instead, which
is what I think most people do.

quinn wildman wrote:
Alan Marryat wrote:
Simply run Delphi, go to the View Menu, to Toolbars, and check Component. Then notice on the "Standard" tab that there are duplicates.

I cannot reproduce the reported behavior. No matter what I do, TPanel
and TActionList only show up once in the standard group.

When I found i in XE2, I switched it back on - I feel like it's quicker to get to components, at least it complements the newer tool palette.

Obviously this isn't a big deal, because I just ran XE2 and noticed it has the same bug. And I hadn't noticed it there in years. Perhaps because in XE7, the toolbar starts on the left side of the IDE rather than in the middle.
quinn wildman

Posts: 856
Registered: 12/2/99
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2014 3:41 PM   in response to: Alan Marryat in response to: Alan Marryat
The Component Toolbar in XE7 looks the same as it has always looked, and
it starts on the left. The standard tab is immediately below the file
menu - which is of course on the far left.

Alan Marryat wrote:
Perhaps because in XE7, the toolbar starts on the left side of the IDE rather than in the middle.
Bo Berglund

Posts: 757
Registered: 10/23/02
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 4, 2015 11:37 PM   in response to: Alan Marryat in response to: Alan Marryat
On Mon, 22 Dec 2014 13:11:04 -0800, Alan Marryat <> wrote:

Simply run Delphi, go to the View Menu, to Toolbars, and check Component.

Is this supposed to be available on Delphi 2007 too? I cannot find it.
I positively hate the fact that the components disappear as soon as a
code view is shown...
Stephan St-Denis

Posts: 8
Registered: 6/18/00
Re: XE7 Component Toolbar duplicate controls  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 13, 2015 10:10 AM   in response to: Alan Marryat in response to: Alan Marryat
Alan Marryat wrote:
Not a big problem, but I have noticed that when the Component Toolbar is enabled, going to the Standard tab, I can see TPanel and TActionlist twice on there. Once near the left side, and again near the right end of the toolbar.

I have the same problem here, except that I have 11 controls that are duplicated on the Standard Tab of the Toolbar (Classic Undocked). I had the same problem back in Delphi XE2. I never used XE2 for that reason and skipped all other XEnn versions until XE7, which have the same problem. What a shame !
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02