Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Release Configuration doesn't appear


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 1 - Last Post: Aug 28, 2014 9:21 PM Last Post By: Alex Belo
Mohammad Alsharif

Posts: 36
Registered: 6/29/14
Release Configuration doesn't appear  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 28, 2014 2:26 AM
Hi all,

I built a project using C++ XE5, and it works perfectly fine. Last step is that I need a copy of my project that can work on any PC (even if it doesn't have XE5 installed).
I think that this is done through the "Release" configuration, but when I activate it and build the project it gives me Success but with no project icon in the "Release"
directory in my PC.

Any idea what to do?

Thanks in Advance
Alex Belo

Posts: 626
Registered: 10/8/06
Re: Release Configuration doesn't appear  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 28, 2014 9:21 PM   in response to: Mohammad Alsharif in response to: Mohammad Alsharif
Mohammad Alsharif wrote:

I built a project using C++ XE5, and it works perfectly fine. Last
step is that I need a copy of my project that can work on any PC
(even if it doesn't have XE5 installed). I think that this is done
through the "Release" configuration, but when I activate it and build
the project it gives me Success but with no project icon in the
"Release" directory in my PC.

I don't know why you have not compiled exe in Release directory (check
paths in project options) but assumption that default release
configuration will automatically generate standalone exe (without
package dependences) is wrong.

Any idea what to do?

I don't know about new studio versions but in older versions you need
in project options:

1) go to linker options and disable dynamic RTL;
2) go to package options and disable building with runtime packages.

--
Alex
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02