Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Gexperts and XE6


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 5 - Last Post: Jun 2, 2014 11:44 AM Last Post By: Markus Humm
Ole Ekerhovd

Posts: 50
Registered: 2/20/03
Gexperts and XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 1, 2014 11:34 AM
When I install Gexperts all the icons for Gexperts are greyed out in a light grey colour.

Is this a known problem?

Regards,
Ole
Steve Faleiro

Posts: 77
Registered: 3/11/01
Re: Gexperts and XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 1, 2014 12:36 PM   in response to: Ole Ekerhovd in response to: Ole Ekerhovd
Ole Ekerhovd wrote:
When I install Gexperts all the icons for Gexperts are greyed out in a light grey colour.

Is this a known problem?

Regards,
Ole

I am experiencing the same (GExperts / Delphi XE6)..
Nicholas Ring

Posts: 54
Registered: 8/22/97
Re: Gexperts and XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 1, 2014 2:08 PM   in response to: Ole Ekerhovd in response to: Ole Ekerhovd
Ole Ekerhovd wrote:

When I install Gexperts all the icons for Gexperts are greyed out in
a light grey colour.

Is this a known problem?

Yes. From Erik Berry (GExperts discussion group)

-- Quote Start --
Note that the GExperts main menu icons appear white when they are
disabled.
I'm not sure why yet. I'm not going to worry too much about it, but if
anyone finds out how to fix it, let me know. I'm assuming it has to do
with
the new XE6 VCL menu theme support, or a change in the way disabled
bitmaps
are auto-generated by the IDE.
--- Quote End ---

Cheers,
Nick

--
Sent from my XanaNews v1.19.1.373

Achim Kalwa

Posts: 70
Registered: 10/22/99
Re: Gexperts and XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2014 2:52 AM   in response to: Nicholas Ring in response to: Nicholas Ring
Nicholas Ring wrote:

Yes. From Erik Berry (GExperts discussion group)

I could not find that discussion in the EMail list; can you provide a
link to that discussion, please?

-- Quote Start --
Note that the GExperts main menu icons appear white when they are
disabled.
I'm not sure why yet. I'm not going to worry too much about it, but if
anyone finds out how to fix it, let me know. I'm assuming it has to do
with
the new XE6 VCL menu theme support, or a change in the way disabled
bitmaps
are auto-generated by the IDE.
--- Quote End ---

If you usually compile GExperts yourself, you can add one line of code
as a workaround to prevent that "light gray" icons. I'm still not sure
what is causing the problem...

Unit GX_ActionBroker.pas

Search for:

procedure TGxActionBroker.RegisterActionWithIde

locate this code:

ReadyBitmap := CreateScaledBitmap(Bitmap);
try
BitmapName := AAction.Name + GetBitmapSuffix;

add:
{$ifdef GX_VER170_up}
ReadyBitmap.Transparent := False; // prevent invisible icons on XE6
{$endif}´╗┐

HTH
Achim

Nicholas Ring

Posts: 54
Registered: 8/22/97
Re: Gexperts and XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2014 4:10 AM   in response to: Achim Kalwa in response to: Achim Kalwa
Achim Kalwa wrote:

Nicholas Ring wrote:

Yes. From Erik Berry (GExperts discussion group)

I could not find that discussion in the EMail list; can you provide a
link to that discussion, please?

Hope this is enough. I get the list emailed to me.
https://groups.yahoo.com/neo/groups/GExpertsDiscuss/conversations/topics/4146;_ylc=X3oDMTM0b2o1ZHM1BF9TAzk3MzU5NzE0BGdycElkAzE5MzMxMDkEZ3Jwc3BJZAMxNzA1MTE1MzYyBG1zZ0lkAzQxNDYEc2VjA2Z0cgRzbGsDdnRwYwRzdGltZQMxMzk3NzkwNDYwBHRwY0lkAzQxNDY-

Cheers,
Nick

--
Sent from my XanaNews v1.19.1.373

Markus Humm

Posts: 5,113
Registered: 11/9/03
Re: Gexperts and XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2014 11:44 AM   in response to: Nicholas Ring in response to: Nicholas Ring
Am 01.06.2014 23:08, schrieb Nicholas Ring:
Ole Ekerhovd wrote:

When I install Gexperts all the icons for Gexperts are greyed out in
a light grey colour.

Is this a known problem?

Yes. From Erik Berry (GExperts discussion group)

-- Quote Start --
Note that the GExperts main menu icons appear white when they are
disabled.
I'm not sure why yet. I'm not going to worry too much about it, but if
anyone finds out how to fix it, let me know. I'm assuming it has to do
with
the new XE6 VCL menu theme support, or a change in the way disabled
bitmaps
are auto-generated by the IDE.
--- Quote End ---

Hello,

it could have to do with a new but still buggy property of TImageList
which is about a grayscalefactor (property is named something like this
but I don't recall the correct name).

When I did some simplistic test with that I got white icons on
TMainMenu. That might be the issue, at least as I interpret the posts here.

Greetings

Markus
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02